Page 1 of 1

Install Unify runtime 5.2 in Windows 2000

PostPosted: Wed Jul 18, 2012 10:11 am
by miguellagos
Hello, when I try to install Unify runtime 5.2 in Windows 2000, this error is displayed:

Unify Runtime 5.2 MSI requires that your computer is
running Windows 2000 or Windows XP or Windows
Server 2003 or Windows Vista


At unify website matrix compatibility list certifies Team Developer 5.2 with Windows 2000.
Anyone has solved this issue?

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Wed Jul 18, 2012 11:01 am
by Jeff Luther
Which version of 5.2, that is what SP? The newest SP5 or an older version? Is the Windows 2000 machine a VM?

Meantime, I will ask internally about what you are reporting.

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Wed Jul 18, 2012 12:14 pm
by Jeff Luther
I just heard back from our QA/Build engineer who replied the following. Note his question I'll put in bold:

"Just now installed successfully on WIN2kSRV-QA. This is Windows 2000 (Build 2195) SP4.

Please ask the user to check if the OS is up-to-date with windows updates."

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Sat Jul 21, 2012 7:07 pm
by miguellagos
Hello Jeff, the version is 5.2 SP2 provided by Infor for their ERP Visual Enterprise. I reported the problem to Infor and they suggested to ask Unify support for this issue.

Information of the exe:
name = runtime52_setup.exe
file size = 43,003,231
Company = Unify Corp
File Version = 5.2.2
Internal Build Number = 92881
Internal Name = Setup
Language = English (United States)
Original File Name = Setup.exe
Product Name = Unify Runtime 5.2 MSI
Product Version = 5.2.2

The Windows 2000 is a physical machine, actually I tried it in two different physical machines with the same result.

All my W2K machines are in SP4 and up to date from my internal WSUS server.


Miguel Lagos

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Mon Jul 23, 2012 1:53 pm
by Jeff Luther
I'm asking internally, but a 5.2 that is 3 SP's old + a runtime that INFOR has given you does add a little complexity to the situation. What is their experience in their testing their product on Win2000 with SP2? TD compat. matrix: http://www.guptatechnologies.com/Products/App_Dev/T ... atrix.aspx

does show that now 5.2 SP5 is compatible with Win2000 and I'm sure it was supposed to be compat. back in SP2 days as well. What I don't know is whether there was a defect fixed after SP2 that fixed what you are seeing.

TELL YOU WHAT I WOULD TRY... Get to Unify's download page: http://www.guptatechnologies.com/Services/productDownloads.aspx
log in and download TD v5.2 SP5 Deployer (that's the runtime) and see if that works to install OK on your Win2000 machine.

I am not suggesting that you use SP5 for your INFOR product -- that's up to them to support what they sell and provide and I don't know anything about the INFOR product -- but I am suggesting that if SP5 will not install, then that would confirm that whatever you are seeing with SP2 is 'real' and still an issue. On the other hand, if SP5 does install... well, might suggest that INFOR needs to upgrade their product and runtime TD release version.

Note in my previous reply that our QA/BUILD engineer tested SP4 and that installed on Win2000 OK.

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Wed Jul 25, 2012 1:17 pm
by Jeff Luther
I heard again from our QA/Build engineer. After I provided him the details of that Info. you wrote, he replied:
Based on the given information [Information of the exe: info], it seems they are using a file with size around to 40MB which is for sure not the TD5.2 SP2 installer.

It mentions something about runtime, I am just guessing that they maybe want to run TD5.2 SP2 deployer on their machine. The one which we shipped is 41,101,880 bytes and the one which they are saying is 43,003,231.

At this point I am not sure what they are exactly running.

He suggested that you may want
to install TD5.2 SP2 runtime only on [your] machine.

Again, this would be a test only, since we have no idea what INFOR is providing for TD v5.2 SP2 runtime -- it would seem to be a superset of what our SP2 is, since the file is larger by a couple meg. Note, that we cannot guarantee that this will work for you nor that it will work with the INFOR product. We are providing this on an as-is basis for testing only.

However, if you want to download and try the original 5.2 SP2 Deplorer I have put it on our FTP site:
ftp://ftp.guptatechnologies.com/outgoing/support/Deploy52SP2.zip

zip file size is ~39meg and that file should remain on our FTP site for a week or so before it is removed.

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Thu Aug 02, 2012 1:20 pm
by miguellagos
Hello, Jeff, I was on vacation, sorry for not answering before.

I installed TD5.2 SP2 runtime you provided me and compared the files installed with the install of a XP machine (the Infor provided runtime).

I decided to replace the different files and add the missing files and it works!!!


Thank you for all your help, and have a nice rest of the day.

I own you a beer.

Miguel Lagos

Re: Install Unify runtime 5.2 in Windows 2000

PostPosted: Fri Aug 03, 2012 10:22 am
by Jeff Luther
Glad SP2 worked for you, Miguel. Thanks for letting us know.