Page 1 of 1

TD62 SP4 Installation Error

PostPosted: Tue Jun 16, 2015 7:09 pm
by Sunil
Hello Support.

This is error while installation Service Pack 4 of TD62 and immediate installer Roll back started.
Please look this issue.

[img]TD62-SP4Error.png[/img]

Regards.
Sunil

Re: TD62 SP4 Installation Error

PostPosted: Wed Jun 17, 2015 7:42 am
by giscon
Same problem here when I tried to install TD6.2 SP4 on a virtual Win-XP machine as I usually do when trying out a new SP or Update.
An update from SP3rUpd2 to SP4 and also a full new Installation of SP4 was not possible, "fatal error" in all cases.
Does TD6.2 SP4 not run anymore on Win XP ?

Kind regards
Günter
Giscon Systems GmbH

Re: TD62 SP4 Installation Error

PostPosted: Wed Jun 17, 2015 8:21 am
by kumuthini.ragavan
You may have to enable digital signature on XP. Can you please try?
Just a guess from the error message. Let us know if it does not help.

Re: TD62 SP4 Installation Error

PostPosted: Wed Jun 17, 2015 9:57 am
by Sunil
Hi kumuthini,

I have enabled it but it is still not working. Please see another possible reasons.

Regards.
Sunil

Re: TD62 SP4 Installation Error

PostPosted: Wed Jun 17, 2015 10:20 am
by giscon
Did again some tries, but until now no success to install TD6.2 SP4 on (virtual) WinXP.
Remember that with all versions before, e.g. the previous one TD6.2 SP3r, there are no problems to install on Win XP. There must be definitely a change in the new tdsetup.exe.

The error occurs nearly at the end of the installation process, you see that it tries "publishing product Information".
Then the error pops up and after confirming the message the whole Installation is rolled back.
TD62-SP4-install-Bug-1.jpg

TD62-SP4-install-Bug_2.jpg


Maybe that the installer now expects a newer .NET-Version (as TD6.3 that can't be installed on WinXP) or searches for a registry entry that cannot exist in Win XP?
Any help appreciated.

Kind regards
Günter
Giscon Systems GmbH

Re: TD62 SP4 Installation Error

PostPosted: Thu Jun 18, 2015 3:26 am
by Sunil
Hello Support.

I am waiting installation issue since two days and for solution of TD22038 since 2011. Now resolved in TD62 SP4 but unable to installed. I am regular GLS customer since 1998. I don't know how long customer has to wait...... .

Regards.
Sunil

Re: TD62 SP4 Installation Error

PostPosted: Thu Jun 18, 2015 7:44 am
by jmgemperle
Hi

I received similar report on WIN7 so I don't think this is specific to XP, XP should still be ok with the SP AFAIK.
System.core is from MS .NET (MSIL NET 4 ) and it is weird the setup reference it either a reference or try to setup it...
Can the people have the problem tell me if .NET 4 is installed on the machine?

Indeed I try on WIN7 and I had the .NET 4.5.1 installed no problem then to install deploy62.exe
But as soon as I remove the .NET 4.5.1 I have this error see attached...
I've try then the full setup and got also that same error, not the same as yours...though.
For the moment not sure what is going on.

I let you know when I have news...

Cheers
JM

Re: TD62 SP4 Installation Error

PostPosted: Fri Jun 19, 2015 1:49 am
by giscon
Hi Jean Marc,

yes, .NET 4 is fully installed with all updates on the XP machine.

Kind regards
Günter
Giscon Systems GmbH

Re: TD62 SP4 Installation Error

PostPosted: Fri Jun 19, 2015 5:09 am
by efarina
Hi

The same problem for PC without Framework 4.5 on Windows 7.
After installing the 4.5 framework, sp4 has successfully installed.

Regards
Eric

Re: TD62 SP4 Installation Error

PostPosted: Fri Jun 19, 2015 10:52 am
by Sunil
Hi ,

I have installed framework 4 and then upgrade to 4.0.3 which is most recent upgrade from Microsoft support on windows xp
and try to installed TD sp4 but failed with similar error as i mentioned at the time of post creation.

I think Gupta Support must look this issue and reply properly which version support or don't support. TD62 SP4 certified by Gupta.

Regards.
Sunil

Re: TD62 SP4 Installation Error

PostPosted: Fri Jun 19, 2015 12:24 pm
by Sunil
Hello Günter,

Can you suggest which updates you applied on XP and able to update TD Sp4 on sp4. I went through google search and found 4.0.30919.34209 is related to .Net 4.5.2 and 4.5.? do not support windows xp. That means TD SP4 will be installed only on windows 7 .

This may help me to install upgrade.

Thanks in Advance.

Regards.
Sunil

Re: TD62 SP4 Installation Error

PostPosted: Mon Jun 22, 2015 12:29 am
by giscon
Hello Sunil,

the .NET Version installed on the XP machine is the full Version of 4.0 (dotNetFx40_Full_x86_x64.exe), the version number is 4.0.30319. All MS Updates for that .NET-Version, mostly security updates, have been installed also.

But as I described above, the Installation of TD6.2 SP4 (or an update from TD6.2 SP3r) is NOT possible, always the above shown error.

Regards,
Günter

Re: TD62 SP4 Installation Error

PostPosted: Mon Jun 22, 2015 7:17 pm
by Sunil
Hello Günter,

Thanks. I have installed but even installation failed and rollback. Gupta support silent on this issue , i think TD62 sp4 is not certified for win-xp which is strange.

I hope , Gupta support reply soon.

Regards.
Sunil

Re: TD62 SP4 Installation Error

PostPosted: Tue Jun 23, 2015 9:59 am
by Uwe van der Horst
Sunil wrote:Gupta support silent on this issue , i think TD62 sp4 is not certified for win-xp which is strange.

We have not tried to install the Deploy62.exe on Win-XP. We have copied the Deployment files via XCOPY and don't see any problems with XP and SP4. So I do agree with JM, SP4 is still ok with XP and this one is an installer issue.

Re: TD62 SP4 Installation Error

PostPosted: Tue Jun 23, 2015 4:59 pm
by Insoft
Hi,

When we were notified at the beginning of April that TD 6.3 was available we had just finished upgraded our client's software from TD 3.1 to TD 6.2 WIN32 version (our update didn't go live until end of April)
I immediately downloaded, and tried to install, TD 6.3 Win32, however I hit the error:

Team Developer 6.3 - InstallShield Wizard
.NET Framework 4.5 or later is required for Team Developer 6.3
Please install it before installing Team Developer 6.3



I queried this as we don't have the .NET version and wanted to know if this is a new undisclosed requirement for the WIN32 version, or an error with the installer, or if we'd been sent to the wrong version download?

Support emailed a reply of :

It's mandatory now because installer does not know if customer won't use GAIL, QuickGraph or SalMail.
ReportBuilder also requires .NET 4.5 if it chart control is used.
Win32 has the “GAIL” feature of calling .NET code from within a win32 app, so if someone uses that then they’ll need the right .NET in place.


I am still hoping for answers to my follow-up questions of:

* Does the DEPLOY63.EXE for TD 6.3 (Win32 version) also enforce the .NET requirement, or can you elect to continue the install without it (for when you know your application does not use any .NET functionality within the WIN32 version)?
* We are using SalMail in our TD6.2 code (but not QuickGraph, Report Builder's ChartControl, or GAIL - which I have never heard of)... does this mean the TD6.2 WIN version also has a .NET Framework requirement? And if so what version is required for TD6.2?
* If TD6.2 does not need any .NET Framework, does SalMail on TD6.3 require the .NET to be able to run, or does it need it only to be able to implement BCC?

While I would consider installing .NET 4.5 for my 2 machines to enable being able to install 6.3 for Development, having to force our client, or any future clients, to ensure all their machines have a required .NET sounds problematic and probably means we are stuck in being unable to upgrade past TD6.2 anytime soon. Are there any plans to remove, or make optional, the .NET requirement from the Win32 install in future releases - if not someone should update the website to let people know any required dependencies.


It looks like these questions now also apply to TD 6.2 SP4...

Timothy
Insoft.