Webservice wizard - consumer problem

Discussions specific to Team Developer 5.1.

Webservice wizard - consumer problem

Postby SteveLeighton » Thu Jan 13, 2011 10:59 pm

Hi
Using TD5.1 PTF6 Webservice wizard to generate Factory and Soap1.2 Service functionality , and using to consume a simple webservice.

Am calling the WebService in a loop repeatedly.

Anywhere between 5 to 50 consecutive calls are successful, but it then consistently returns either:
10208 :: No response came back from the web service’
or sometimes ( but rarely )
Input stream is NULL in msg_ctx’ , in sFaultBody whenever SOAPConsumer_LoadResponse() returns false

The Soap log immediately before the crash always contains …
[info] Invoking web service operation.
[info] <<< Begin Payload >>>
[info] <tdwsns:getSales xmlns:http="http://schemas.xmlsoap.org/wsdl/http/" xmlns:tm="http://microsoft.com/wsdl/mime/textMatching/" xmlns:tdwsns="http://api.urldeleted.com/" xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:s="http://www.w3.org/2001/XMLSchema" xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" xmlns:mime="http://schemas.xmlsoap.org/wsdl/mime/" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"><tdwsns:accesscode>blah!</tdwsns:accesscode><tdwsns:LastUpdatedFrom>21-Oct-2010 2:55:09 PM</tdwsns:LastUpdatedFrom><tdwsns:LastUpdatedTo>28-Oct-2010 2:55:09 PM</tdwsns:LastUpdatedTo></tdwsns:getSales>
[info] <<< End Payload >>>
[error] ..\..\src\core\transport\http\sender\http_sender.c(528) status_code < 0
[info] Loading response...
[info] .....no response received


Anyone had similar issue ? Is this a problem at the consumer ( eg memory ) end or the server end.

Any clues gratefully recieved.
Best wishes
Steve
Bankside Systems Ltd. ( New Zealand )
http://www.banksidesystems.co.uk
Image
Go forward! Come join the TD, SqlBase & TDMobile community on
Team Developer Community Forum
User avatar
SteveLeighton
 
Posts: 114
Joined: Tue Jan 15, 2008 7:50 am
Location: Tauranga, New Zealand

Return to Team Developer 5.1

Who is online

Users browsing this forum: No registered users and 1 guest