Windows 7 + library problems

Discussions specific to Team Developer 5.1.

Windows 7 + library problems

Postby Infohos » Thu Jun 10, 2010 5:25 am

Hi,

We have installed a windows 7 enterprise system with TD 5.1 with SP6.
When we try to compile our application we get the following message:
Cannot load or find external library (or one of its components). Check to ensure the path ....
library name it gets stuck is WSOCK32.DLL but also Odbccp32.dll.
The compiler blocks on this so i'm guessing here but i think there will be some more.

Can anyone help us?

Thanks a lot.
Infohos
 
Posts: 2
Joined: Thu Jun 10, 2010 5:12 am

Re: Windows 7 + library problems

Postby jmcnamara » Thu Jun 10, 2010 6:13 am

Try running TD as Administrator - it sounds like a permissions issue.
jmcnamara
 
Posts: 117
Joined: Thu Dec 13, 2007 9:39 am

Re: Windows 7 + library problems

Postby Infohos » Thu Jun 10, 2010 6:42 am

Doesn't help if I open it via RMB then "run as administrator"
Same issue
Infohos
 
Posts: 2
Joined: Thu Jun 10, 2010 5:12 am

Re: Windows 7 + library problems

Postby shawnmuller » Wed Jul 14, 2010 1:14 am

Hi

I now have the same problem. With Winsock and qtabi51.dll. I originally had some more errors, but after installing samples, it is mostly OK. I tried registering teh relevant dll's, but that was unsuccessful.

The problem on my side can be reproduced if you try and compile qcktabs.app or qcktabs.apl

TD 5.1 SP6 Windows 7

Running cbi51.exe as administrator

Thanks,
Shawn
shawnmuller
 
Posts: 15
Joined: Wed Oct 22, 2008 7:57 pm

Re: Windows 7 + library problems

Postby slong » Fri Sep 16, 2011 4:22 am

Hi,

I 've got the same problem but with vti51.dll.
Did you find a solutions so far?
slong
 
Posts: 9
Joined: Mon Jul 20, 2009 4:42 pm

Re: Windows 7 + library problems

Postby lrcuess » Sun Sep 18, 2011 11:35 pm

Hello,

just guessing, but do you guys have the DLLs that cannot be loaded located in your applications project-directory?
Especially wsock32.dll and odbccp32.dll are system modules and should not be delivered with your software!
So just remove them from your project directory and TD will load the modules originally shipped with your operating system.
(From %windir%\system32 or on 64 Bit systems from %windir%\SysWOW64.)
That should solve some issues.

For qtabi51.dll and vti51.dll try to use Dependency Walker (http://www.dependencywalker.com/).
It will show you, which DLLs are additionally needed to load them.
Maybe you just have to install the appropriate Microsoft C/C++ Runtime version (which is Visual C 2005 SP1) to use them.
(http://www.microsoft.com/download/en/de ... px?id=5638)

I hope this helps!

Greetings,
Max
Markus Eßmayr
RACON Software GmbH
http://www.racon.at
User avatar
lrcuess
 
Posts: 1163
Joined: Mon May 07, 2007 5:58 am
Location: Linz, Austria

Re: Windows 7 + library problems

Postby slong » Fri Sep 23, 2011 1:13 am

Hi,

it still does not work.
I checked the dependencies with the DependencyWalker and 3 DLL were shown, that could not be found - but they exist in the c:\windows\... folders.
I´m a bit confused...
I also installed the Runtime library, but also with no access.
Any further ideas?

Best regards
Sabine
slong
 
Posts: 9
Joined: Mon Jul 20, 2009 4:42 pm

Re: Windows 7 + library problems

Postby lrcuess » Fri Sep 23, 2011 3:36 am

Hi,

could you please post an APT file with just the External Functions definitions in it, that don't work?

Max
Markus Eßmayr
RACON Software GmbH
http://www.racon.at
User avatar
lrcuess
 
Posts: 1163
Joined: Mon May 07, 2007 5:58 am
Location: Linz, Austria

Re: Windows 7 + library problems

Postby jmcnamara » Mon Sep 26, 2011 6:32 am

Did you install it on a network or local drive? If it's on the network you'll probably have to add permissions using 'caspol'.
jmcnamara
 
Posts: 117
Joined: Thu Dec 13, 2007 9:39 am

Re: Windows 7 + library problems

Postby slong » Fri Oct 07, 2011 1:17 am

Hi,

attached you can find the following APT-Files:

basic.apt this includes external library vtdos.apl
vtdos.apt this includes vti51.dll (which cannot be found, even if it is definitly in the same directory)

I am working on a local machine, not in a network.

Thanks a lot for your help!!!
You do not have the required permissions to view the files attached to this post.
slong
 
Posts: 9
Joined: Mon Jul 20, 2009 4:42 pm

Re: Windows 7 + library problems

Postby lrcuess » Sun Oct 09, 2011 10:42 pm

Hi,

I've no problems so far.
Could you download and install Process Monitor to get a trace what's going on?


Thank you!
Max
Markus Eßmayr
RACON Software GmbH
http://www.racon.at
User avatar
lrcuess
 
Posts: 1163
Joined: Mon May 07, 2007 5:58 am
Location: Linz, Austria

Re: Windows 7 + library problems

Postby slong » Mon Oct 10, 2011 1:49 am

Hi,

I include the logfile. Hope I did the right thing.... :(

Thanks,
Sabine
slong
 
Posts: 9
Joined: Mon Jul 20, 2009 4:42 pm


Return to Team Developer 5.1

Who is online

Users browsing this forum: No registered users and 1 guest