incorrect version of library after migrating from 1.5.1

Discussions specific to Team Developer 5.1.

incorrect version of library after migrating from 1.5.1

Postby michel demey » Wed Jul 17, 2013 2:45 am

Hi,

So I finally succeeded in compiling my old 1.5.1 code to td 5.1.

When I start it, I can't connect to our Sybase db, and receive the "9283 incorrect version of library" error.

What I already checked :
- the path : 5.1 entries are above 1.5.1 entries.
- with process explorer, the dll that are loaded. None of the 1.5.1 dll are loaded, only the 5.1 ones. Five dll from the sybase client are loaded.
- sql.ini I used the ini created with the install, and added all the necessary from my old sql.ini file.
- sqltalk : I don't have the 9283 error here, but a "cannot open database". With process explorer, the same dll are loaded...

What hides behind the 9283 error? Could it be that the sybase client should be upgraded?

Michel
michel demey
 
Posts: 1
Joined: Wed Jul 17, 2013 2:29 am

Re: incorrect version of library after migrating from 1.5.1

Postby Charlie » Thu Jul 18, 2013 3:31 am

G'day Michel,

When we upgraded from TD2.1 to TD5.2, we had to upgrade the Oracle client.

I imagine the same thing would need to be done for any database product, going from really old versions of TD to the more recent ones.
Image

Come join us at Dave Rabelink's "Team Developer Community Forum"!
All users of OpenText™ Gupta Development Tools and Databases welcome!
http://tdforum.daverabelink.net/index.php
Charlie
 
Posts: 345
Joined: Mon Mar 10, 2008 5:04 am
Location: New Brunswick, Canada


Return to Team Developer 5.1

Who is online

Users browsing this forum: No registered users and 1 guest

cron